What’s Vulnerable › Vulnerabilities

CVE-2019-1002100

Description

In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.

Affected products

How to fix

Upgrade to a fixed version: Kubernetes 1.11.8, 1.12.6, 1.13.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-1002100 or the next vulnerability affects your stack