What’s Vulnerable › Vulnerabilities
CVE-2019-10061
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-26 · updated 2026-06-17
- Weakness: CWE-78
Description
utils/find-opencv.js in node-opencv (aka OpenCV bindings for Node.js) prior to 6.1.0 is vulnerable to Command Injection. It does not validate user input allowing attackers to execute arbitrary commands.
Affected products
- HackerOne node-opencv node module: before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: HackerOne node-opencv node module 6.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/peterbraden/node-opencv/commit/81a4b8620188e89f7e4fc985f3c89b58d4bcc86b
- https://github.com/peterbraden/node-opencv/commit/aaece6921d7368577511f06c94c99dd4e9653563
- https://www.npmjs.com/advisories/789
- https://github.com/peterbraden/node-opencv/commit/81a4b8620188e89f7e4fc985f3c89b58d4bcc86b
- https://github.com/peterbraden/node-opencv/commit/aaece6921d7368577511f06c94c99dd4e9653563
- https://www.npmjs.com/advisories/789
Get alerted when CVE-2019-10061 or the next vulnerability affects your stack