What’s Vulnerable › Vulnerabilities
CVE-2019-10085
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-19 · updated 2026-06-17
- Weakness: CWE-79
Description
In Apache Allura prior to 1.11.0, a vulnerability exists for stored XSS on the user dropdown selector when creating or editing tickets. The XSS executes when a user engages with that dropdown on that page.
Affected products
- Apache Software Foundation Apache Allura: before 1.11.0 — fixed in 1.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Allura 1.11.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108816
- https://lists.apache.org/thread.html/88c064c95da2f41d5435ca5b3e364925bed72cc73bcec9b3f25e4c07%40%3Cdev.allura.apache.org%3E
- https://lists.apache.org/thread.html/9a20914c4251a2ae3caebd8d0dd0056f3ac89209d6c216bb89efabd9%40%3Cannounce.apache.org%3E
- http://www.securityfocus.com/bid/108816
- https://lists.apache.org/thread.html/88c064c95da2f41d5435ca5b3e364925bed72cc73bcec9b3f25e4c07%40%3Cdev.allura.apache.org%3E
- https://lists.apache.org/thread.html/9a20914c4251a2ae3caebd8d0dd0056f3ac89209d6c216bb89efabd9%40%3Cannounce.apache.org%3E
Get alerted when CVE-2019-10085 or the next vulnerability affects your stack