What’s Vulnerable › Vulnerabilities
CVE-2019-1010083
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-17 · updated 2026-06-17
Description
The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.
Affected products
- pallets flask: before 1.0 — fixed in 1.0
How to fix
Upgrade to a fixed version: pallets flask 1.0. Check the vendor advisory for mitigations.
References
- https://www.palletsprojects.com/blog/flask-1-0-released/
- https://www.palletsprojects.com/blog/flask-1-0-released/
Get alerted when CVE-2019-1010083 or the next vulnerability affects your stack