What’s Vulnerable › Vulnerabilities
CVE-2019-1010127
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-25 · updated 2026-06-17
- Weakness: CWE-416
Description
VCFTools vcftools prior to version 0.1.15 is affected by: Use-after-free. The impact is: Denial of Service or possibly other impact (eg. code execution or information disclosure). The component is: The header::add_FILTER_descriptor method in header.cpp. The attack vector is: The victim must open a specially crafted VCF file.
Affected products
- vcftools: before 0.1.15 — fixed in 0.1.15
How to fix
Upgrade to a fixed version: vcftools 0.1.15. Check the vendor advisory for mitigations.
References
- https://docs.google.com/document/d/e/2PACX-1vQJveVcGMp_NMdBY5Je2K2k63RoCYznvKjJk5u1wJRmLotvwQkG5qiqZjpABcOkjzj49wkwGweiFwrc/pub
- https://github.com/vcftools/vcftools/issues/141
- https://docs.google.com/document/d/e/2PACX-1vQJveVcGMp_NMdBY5Je2K2k63RoCYznvKjJk5u1wJRmLotvwQkG5qiqZjpABcOkjzj49wkwGweiFwrc/pub
- https://github.com/vcftools/vcftools/issues/141
Get alerted when CVE-2019-1010127 or the next vulnerability affects your stack