What’s Vulnerable › Vulnerabilities
CVE-2019-1010161
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-25 · updated 2026-06-17
- Weakness: CWE-347
Description
perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.
Affected products
- perl-CRYPT-JWT: through 0.022
References
- https://github.com/DCIT/perl-Crypt-JWT/issues/3#issuecomment-417947483
- https://github.com/DCIT/perl-Crypt-JWT/issues/3#issuecomment-417947483
Get alerted when CVE-2019-1010161 or the next vulnerability affects your stack