What’s Vulnerable › Vulnerabilities
CVE-2019-1010174
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-25 · updated 2026-06-17
- Weakness: CWE-77
Description
CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.
Affected products
- Cimg Library: before 2.3.4 — fixed in 2.3.4
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Cimg Library 2.3.4. Check the vendor advisory for mitigations.
References
- https://framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146
- https://lists.debian.org/debian-lts-announce/2019/09/msg00030.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00033.html
- https://framagit.org/dtschump/CImg/commit/5ce7a426b77f814973e56182a0e76a2b04904146
- https://lists.debian.org/debian-lts-announce/2019/09/msg00030.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00033.html
Get alerted when CVE-2019-1010174 or the next vulnerability affects your stack