What’s Vulnerable › Vulnerabilities
CVE-2019-1010180
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-24 · updated 2026-10-14
- Weakness: CWE-125
Description
GNU gdb All versions is affected by: Buffer Overflow - Out of bound memory access. The impact is: Deny of Service, Memory Disclosure, and Possible Code Execution. The component is: The main gdb module. The attack vector is: Open an ELF for debugging. The fixed version is: Not fixed yet.
Affected products
- GNU gdb: before 9.1 — fixed in 9.1
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: GNU gdb 9.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00029.html
- http://www.securityfocus.com/bid/109367
- https://security.gentoo.org/glsa/202003-31
- https://sourceware.org/bugzilla/show_bug.cgi?id=23657
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00029.html
- http://www.securityfocus.com/bid/109367
Get alerted when CVE-2019-1010180 or the next vulnerability affects your stack