What’s Vulnerable › Vulnerabilities
CVE-2019-1010182
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-25 · updated 2026-06-17
- Weakness: CWE-674
Description
yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.
Affected products
- yaml-rust: through 0.4.0
References
Get alerted when CVE-2019-1010182 or the next vulnerability affects your stack