What’s Vulnerable › Vulnerabilities
CVE-2019-1010190
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-24 · updated 2026-06-17
- Weakness: CWE-125
Description
mgetty prior to 1.2.1 is affected by: out-of-bounds read. The impact is: DoS, the program may crash if the memory is not mapped. The component is: putwhitespan() in g3/pbm2g3.c. The attack vector is: Local, the victim must open a specially crafted file. The fixed version is: 1.2.1.
Affected products
- mgetty: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: mgetty 1.2.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00016.html
- https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty/
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00016.html
- https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty/
Get alerted when CVE-2019-1010190 or the next vulnerability affects your stack