What’s Vulnerable › Vulnerabilities
CVE-2019-1010247
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
ZmartZone IAM mod_auth_openidc 2.3.10.1 and earlier is affected by: Cross Site Scripting (XSS). The impact is: Redirecting the user to a phishing page or interacting with the application on behalf of the user. The component is: File: src/mod_auth_openidc.c, Line: 3109. The fixed version is: 2.3.10.2.
Affected products
- OpenIDC mod_auth_openidc: before 2.3.10.2 — fixed in 2.3.10.2
How to fix
Upgrade to a fixed version: OpenIDC mod_auth_openidc 2.3.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/zmartzone/mod_auth_openidc/commit/132a4111bf3791e76437619a66336dce2ce4c79b
- https://github.com/zmartzone/mod_auth_openidc/releases/tag/v2.3.10.2
- https://lists.debian.org/debian-lts-announce/2019/08/msg00029.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00028.html
- https://www.compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2019-001_mod_auth_openidc_reflected_xss.txt
- https://github.com/zmartzone/mod_auth_openidc/commit/132a4111bf3791e76437619a66336dce2ce4c79b
- https://github.com/zmartzone/mod_auth_openidc/releases/tag/v2.3.10.2
- https://lists.debian.org/debian-lts-announce/2019/08/msg00029.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00028.html
- https://www.compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2019-001_mod_auth_openidc_reflected_xss.txt
Get alerted when CVE-2019-1010247 or the next vulnerability affects your stack