What’s Vulnerable › Vulnerabilities
CVE-2019-1010260
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-02 · updated 2026-06-17
- Weakness: CWE-319
Description
Using ktlint to download and execute custom rulesets can result in arbitrary code execution as the served jars can be compromised by a MITM. This attack is exploitable via Man in the Middle of the HTTP connection to the artifact servers. This vulnerability appears to have been fixed in 0.30.0 and later; after commit 5e547b287d6c260d328a2cb658dbe6b7a7ff2261.
Affected products
- ktlint: before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: ktlint 0.30.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-1010260 or the next vulnerability affects your stack