What’s Vulnerable › Vulnerabilities
CVE-2019-1010263
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-17 · updated 2026-06-17
- Weakness: CWE-347
Description
Perl Crypt::JWT prior to 0.023 is affected by: Incorrect Access Control. The impact is: allow attackers to bypass authentication by providing a token by crafting with hmac(). The component is: JWT.pm, line 614. The attack vector is: network connectivity. The fixed version is: after commit b98a59b42ded9f9e51b2560410106207c2152d6c.
Affected products
- Perl Crypt::JWT: before 0.023 — fixed in 0.023
How to fix
Upgrade to a fixed version: Perl Crypt::JWT 0.023. Check the vendor advisory for mitigations.
References
- https://github.com/DCIT/perl-Crypt-JWT/commit/b98a59b42ded9f9e51b2560410106207c2152d6c
- https://www.openwall.com/lists/oss-security/2018/09/07/1
- https://github.com/DCIT/perl-Crypt-JWT/commit/b98a59b42ded9f9e51b2560410106207c2152d6c
- https://www.openwall.com/lists/oss-security/2018/09/07/1
Get alerted when CVE-2019-1010263 or the next vulnerability affects your stack