What’s Vulnerable › Vulnerabilities
CVE-2019-1010275
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-17 · updated 2026-06-17
- Weakness: CWE-295
Description
helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.
Affected products
- helm: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: helm 2.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/pull/3152
- https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50
- https://github.com/helm/helm/releases/tag/v2.7.2
- https://github.com/helm/helm/pull/3152
- https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50
- https://github.com/helm/helm/releases/tag/v2.7.2
Get alerted when CVE-2019-1010275 or the next vulnerability affects your stack