What’s Vulnerable › Vulnerabilities
CVE-2019-1010292
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Linaro/OP-TEE OP-TEE Prior to version v3.4.0 is affected by: Boundary checks. The impact is: This could lead to corruption of any memory which the TA can access. The component is: optee_os. The fixed version is: v3.4.0.
Affected products
- Linaro/OP-TEE OP-TEE: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Linaro/OP-TEE OP-TEE 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/OP-TEE/optee_os/commit/e3adcf566cb278444830e7badfdcc3983e334fd1
- https://github.com/OP-TEE/optee_os/commit/e3adcf566cb278444830e7badfdcc3983e334fd1
Get alerted when CVE-2019-1010292 or the next vulnerability affects your stack