What’s Vulnerable › Vulnerabilities
CVE-2019-10103
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-03 · updated 2026-06-17
- Weakness: CWE-311
Description
JetBrains IntelliJ IDEA projects created using the Kotlin (JS Client/JVM Server) IDE Template were resolving Gradle artifacts using an http connection, potentially allowing an MITM attack. This issue, which was fixed in Kotlin plugin version 1.3.30, is similar to CVE-2019-10101.
Affected products
- JetBrains Kotlin: before 1.3.30 — fixed in 1.3.30
How to fix
Upgrade to a fixed version: JetBrains Kotlin 1.3.30. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
- https://security.netapp.com/advisory/ntap-20230818-0012/
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
- https://security.netapp.com/advisory/ntap-20230818-0012/
Get alerted when CVE-2019-10103 or the next vulnerability affects your stack