What’s Vulnerable › Vulnerabilities
CVE-2019-10104
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-03 · updated 2026-06-17
Description
In several JetBrains IntelliJ IDEA Ultimate versions, an Application Server run configuration (for Tomcat, Jetty, Resin, or CloudBees) with the default setting allowed a remote attacker to execute code when the configuration is running, because a JMX server listened on all interfaces instead of localhost only. The issue has been fixed in the following versions: 2018.3.4, 2018.2.8, 2018.1.8, and 2017.3.7.
Affected products
- JetBrains IntelliJ IDEA: from 2018.1 before 2018.1.8; from 2018.2 before 2018.2.8; from 2018.3 before 2018.3.4; from 2018.3.5 before 2018.3.7 — fixed in 2018.1.8, 2018.2.8, 2018.3.4, 2018.3.7
How to fix
Upgrade to a fixed version: JetBrains IntelliJ IDEA 2018.1.8, 2018.2.8, 2018.3.4, 2018.3.7. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
Get alerted when CVE-2019-10104 or the next vulnerability affects your stack