What’s Vulnerable › Vulnerabilities
CVE-2019-10113
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-16 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.7.8, 11.8.x before 11.8.4, and 11.9.x before 11.9.2. Making concurrent GET /api/v4/projects/<id>/languages requests may allow Uncontrolled Resource Consumption.
Affected products
- GitLab: before 11.7.8; from 11.8.0 before 11.8.4; from 11.9.0 before 11.9.2 — fixed in 11.7.8, 11.8.4, 11.9.2
How to fix
Upgrade to a fixed version: GitLab 11.7.8, 11.8.4, 11.9.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54977
- https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/54977
Get alerted when CVE-2019-10113 or the next vulnerability affects your stack