What’s Vulnerable › Vulnerabilities
CVE-2019-10129
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-125
Description
A vulnerability was found in postgresql versions 11.x prior to 11.3. Using a purpose-crafted insert to a partitioned table, an attacker can read arbitrary bytes of server memory. In the default configuration, any user can create a partitioned table suitable for this attack. (Exploit prerequisites are the same as for CVE-2018-1052).
Affected products
- PostgreSQL: from 11.0 before 11.3 — fixed in 11.3
How to fix
Upgrade to a fixed version: PostgreSQL 11.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10129
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1939/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10129
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1939/
Get alerted when CVE-2019-10129 or the next vulnerability affects your stack