What’s Vulnerable › Vulnerabilities
CVE-2019-10130
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row-level security prunes the set of rows visible to the attacker.
Affected products
- openSUSE Leap: 15.1
- PostgreSQL: from 9.5.0 before 9.5.17; from 9.6.0 before 9.6.13; from 10.0 before 10.8; from 11.0 before 11.3 — fixed in 10.8, 11.3, 9.5.17, 9.6.13
How to fix
Upgrade to a fixed version: PostgreSQL 10.8, 11.3, 9.5.17, 9.6.13. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10130
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1939/
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10130
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1939/
Get alerted when CVE-2019-10130 or the next vulnerability affects your stack