What’s Vulnerable › Vulnerabilities
CVE-2019-10131
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-30 · updated 2026-06-17
- Weakness: CWE-193
Description
An off-by-one read vulnerability was discovered in ImageMagick before version 7.0.7-28 in the formatIPTCfromBuffer function in coders/meta.c. A local attacker may use this flaw to read beyond the end of the buffer or to crash the program.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10, 19.04
- Debian Linux: 9.0
- ImageMagick: before 6.9.9-40; from 7.0.0-0 before 7.0.7-28 — fixed in 6.9.9-40, 7.0.7-28
- openSUSE Leap: 42.3
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-40, 7.0.7-28. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00001.html
- http://www.securityfocus.com/bid/108117
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10131
- https://github.com/ImageMagick/ImageMagick/commit/cb1214c124e1bd61f7dd551b94a794864861592e
- https://lists.debian.org/debian-lts-announce/2020/08/msg00030.html
- https://usn.ubuntu.com/4034-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00001.html
- http://www.securityfocus.com/bid/108117
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10131
- https://github.com/ImageMagick/ImageMagick/commit/cb1214c124e1bd61f7dd551b94a794864861592e
Get alerted when CVE-2019-10131 or the next vulnerability affects your stack