What’s Vulnerable › Vulnerabilities
CVE-2019-10135
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-11 · updated 2026-06-17
- Weakness: CWE-502
Description
A flaw was found in the yaml.load() function in the osbs-client versions since 0.46 before 0.56.1. Insecure use of the yaml.load() function allowed the user to load any suspicious object for code execution via the parsing of malicious YAML files.
Affected products
- Red Hat osbs-client: from 0.46 before 0.56.1 — fixed in 0.56.1
How to fix
Upgrade to a fixed version: Red Hat osbs-client 0.56.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10135
- https://github.com/containerbuildsystem/osbs-client/pull/865
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10135
- https://github.com/containerbuildsystem/osbs-client/pull/865
Get alerted when CVE-2019-10135 or the next vulnerability affects your stack