What’s Vulnerable › Vulnerabilities
CVE-2019-10142
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-119
Description
A flaw was found in the Linux kernel's freescale hypervisor manager implementation, kernel versions 5.0.x up to, excluding 5.0.17. A parameter passed to an ioctl was incorrectly validated and used in size calculations for the page size calculation. An attacker can use this flaw to crash the system, corrupt memory, or create other adverse security affects.
Affected products
- Linux kernel: from 5.0 before 5.0.17 — fixed in 5.0.17
How to fix
Upgrade to a fixed version: Linux kernel 5.0.17. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10142
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10142
Get alerted when CVE-2019-10142 or the next vulnerability affects your stack