What’s Vulnerable › Vulnerabilities
CVE-2019-10153
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-172
Description
A flaw was discovered in fence-agents, prior to version 4.3.4, where using non-ASCII characters in a guest VM's comment or other fields would cause fence_rhevm to exit with an exception. In cluster environments, this could lead to preventing automated recovery or otherwise denying service to clusters of which that VM is a member.
Affected products
- fence-agents: before 4.3.4 — fixed in 4.3.4
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: fence-agents 4.3.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:2037
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10153
- https://github.com/ClusterLabs/fence-agents/pull/255
- https://github.com/ClusterLabs/fence-agents/pull/272
- https://access.redhat.com/errata/RHSA-2019:2037
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10153
- https://github.com/ClusterLabs/fence-agents/pull/255
- https://github.com/ClusterLabs/fence-agents/pull/272
Get alerted when CVE-2019-10153 or the next vulnerability affects your stack