What’s Vulnerable › Vulnerabilities
CVE-2019-10154
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-26 · updated 2026-06-17
- Weakness: CWE-285
Description
A flaw was found in Moodle before versions 3.7, 3.6.4. A web service fetching messages was not restricted to the current user's conversations.
Affected products
- Moodle: before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: Moodle 3.6.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10154
- https://moodle.org/mod/forum/discuss.php?d=386521
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10154
- https://moodle.org/mod/forum/discuss.php?d=386521
Get alerted when CVE-2019-10154 or the next vulnerability affects your stack