What’s Vulnerable › Vulnerabilities
CVE-2019-10160
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-07 · updated 2026-10-14
- Weakness: CWE-172
Description
A security regression of CVE-2019-9636 was discovered in python since commit d537ab0ff9767ef024f26246899728f0116b1ec3 affecting versions 2.7, 3.5, 3.6, 3.7 and from v3.8.0a4 through v3.8.0b1, which still allows an attacker to exploit CVE-2019-9636 by abusing the user and password parts of a URL. When an application parses user-supplied URLs to store cookies, authentication credentials, or other kind of information, it is possible for an attacker to provide specially crafted URLs to make the application locate host-related information (e.g. cookies, authentication data) and send them to a different host than where it should, unlike if the URLs had been correctly parsed. The result of an attack may vary based on the application.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 29, 30, 31
- NetApp Cloud Backup: all versions
- NetApp Converged Systems Advisor Agent: all versions
- openSUSE Leap: 15.0, 15.1
- Python: from 2.7.0 before 2.7.17; from 3.5.0 before 3.5.8; from 3.6.0 before 3.6.9; from 3.7.0 before 3.7.4; 3.8.0-alpha4, 3.8.0-beta1 — fixed in 2.7.17, 3.5.8, 3.6.9, 3.7.4
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.6
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: Python 2.7.17, 3.5.8, 3.6.9, 3.7.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00040.html
- https://access.redhat.com/errata/RHSA-2019:1587
- https://access.redhat.com/errata/RHSA-2019:1700
- https://access.redhat.com/errata/RHSA-2019:2437
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10160
- https://github.com/python/cpython/commit/250b62acc59921d399f0db47db3b462cd6037e09
- https://github.com/python/cpython/commit/8d0ef0b5edeae52960c7ed05ae8a12388324f87e
- https://github.com/python/cpython/commit/f61599b050c621386a3fc6bc480359e2d3bb93de
- https://github.com/python/cpython/commit/fd1771dbdd28709716bd531580c40ae5ed814468
- https://lists.apache.org/thread.html/r1b103833cb5bc8466e24ff0ecc5e75b45a705334ab6a444e64e840a0%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2019/06/msg00022.html
Get alerted when CVE-2019-10160 or the next vulnerability affects your stack