What’s Vulnerable › Vulnerabilities
CVE-2019-10162
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.10, 4.0.8 allowing an authorized user to cause the server to exit by inserting a crafted record in a MASTER type zone under their control. The issue is due to the fact that the Authoritative Server will exit when it runs into a parsing error while looking up the NS/A/AAAA records it is about to use for an outgoing notify.
Affected products
- openSUSE Leap: 15.0, 15.1
- PowerDNS Authoritative: from 4.0.0 before 4.0.8; from 4.1.0 before 4.1.10; 4.0.0 — fixed in 4.0.8, 4.1.10
How to fix
Upgrade to a fixed version: PowerDNS Authoritative 4.0.8, 4.1.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00054.html
- https://blog.powerdns.com/2019/06/21/powerdns-authoritative-server-4-0-8-and-4-1-10-released/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10162
- https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-04.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00054.html
- https://blog.powerdns.com/2019/06/21/powerdns-authoritative-server-4-0-8-and-4-1-10-released/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10162
- https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-04.html
Get alerted when CVE-2019-10162 or the next vulnerability affects your stack