What’s Vulnerable › Vulnerabilities
CVE-2019-10163
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-770
Description
A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent any further updates to any slave zone by sending a large number of NOTIFY messages. Note that only servers configured as slaves are affected by this issue.
Affected products
- openSUSE Backports: sle-15, sle-15-sp1
- openSUSE Leap: 15.0, 15.1
- PowerDNS Authoritative: from 4.0.0 before 4.0.8; from 4.1.0 before 4.1.9; 4.1.0 — fixed in 4.0.8, 4.1.9
How to fix
Upgrade to a fixed version: PowerDNS Authoritative 4.0.8, 4.1.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00054.html
- https://blog.powerdns.com/2019/06/21/powerdns-authoritative-server-4-0-8-and-4-1-10-released/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10163
- https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-05.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00054.html
- https://blog.powerdns.com/2019/06/21/powerdns-authoritative-server-4-0-8-and-4-1-10-released/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10163
- https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-05.html
Get alerted when CVE-2019-10163 or the next vulnerability affects your stack