What’s Vulnerable › Vulnerabilities
CVE-2019-10164
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-26 · updated 2026-06-17
- Weakness: CWE-121
Description
PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a stack-based buffer by changing the user's own password to a purpose-crafted value. This often suffices to execute arbitrary code as the PostgreSQL operating system account.
Affected products
- Fedoraproject Fedora: 29, 30
- openSUSE Leap: 15.0, 15.1
- PostgreSQL: from 10.0 before 10.9; from 11.0 before 11.4 — fixed in 10.9, 11.4
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: PostgreSQL 10.9, 11.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00035.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10164
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MAGE6H4FWLKFLHLWVYNPYGQRPIXTUWGB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TTKEHXGDXYYD6WYDIIQJP4GDQJSENDJK/
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1949/
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00035.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10164
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MAGE6H4FWLKFLHLWVYNPYGQRPIXTUWGB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TTKEHXGDXYYD6WYDIIQJP4GDQJSENDJK/
- https://security.gentoo.org/glsa/202003-03
- https://www.postgresql.org/about/news/1949/
Get alerted when CVE-2019-10164 or the next vulnerability affects your stack