What’s Vulnerable › Vulnerabilities
CVE-2019-10167
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-02 · updated 2026-06-17
- Weakness: CWE-250
Description
The virConnectGetDomainCapabilities() libvirt API, versions 4.x.x before 4.10.1 and 5.x.x before 5.4.1, accepts an "emulatorbin" argument to specify the program providing emulation for a domain. Since v1.2.19, libvirt will execute that program to probe the domain's capabilities. Read-only clients could specify an arbitrary path for this argument, causing libvirtd to execute a crafted executable with its own privileges.
Affected products
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- libvirt: from 4.0.0 before 4.10.1; from 5.0.0 before 5.4.1 — fixed in 4.10.1, 5.4.1
- RedHat Virtualization: 4.3
How to fix
Upgrade to a fixed version: libvirt 4.10.1, 5.4.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/libvirt-privesc-vulnerabilities
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10167
- https://security.gentoo.org/glsa/202003-18
- https://access.redhat.com/libvirt-privesc-vulnerabilities
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10167
- https://security.gentoo.org/glsa/202003-18
Get alerted when CVE-2019-10167 or the next vulnerability affects your stack