What’s Vulnerable › Vulnerabilities

CVE-2019-10168

Description

The virConnectBaselineHypervisorCPU() and virConnectCompareHypervisorCPU() libvirt APIs, 4.x.x before 4.10.1 and 5.x.x before 5.4.1, accept an "emulator" argument to specify the program providing emulation for a domain. Since v1.2.19, libvirt will execute that program to probe the domain's capabilities. Read-only clients could specify an arbitrary path for this argument, causing libvirtd to execute a crafted executable with its own privileges.

Affected products

How to fix

Upgrade to a fixed version: libvirt 4.10.1, 5.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10168 or the next vulnerability affects your stack