What’s Vulnerable › Vulnerabilities
CVE-2019-10169
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-08 · updated 2026-06-17
- Weakness: CWE-267
Description
A flaw was found in Keycloak’s user-managed access interface, where it would permit a script to be set in the UMA policy. This flaw allows an authenticated attacker with UMA permissions to configure a malicious script to trigger and execute arbitrary code with the permissions of the user running application.
Affected products
- Keycloak: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: Keycloak 8.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10169
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10169
Get alerted when CVE-2019-10169 or the next vulnerability affects your stack