What’s Vulnerable › Vulnerabilities
CVE-2019-10196
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-19 · updated 2026-06-17
- Weakness: CWE-665
Description
A flaw was found in http-proxy-agent, prior to version 2.1.0. It was discovered http-proxy-agent passes an auth option to the Buffer constructor without proper sanitization. This could result in a Denial of Service through the usage of all available CPU resources and data exposure through an uninitialized memory leak in setups where an attacker could submit typed input to the auth parameter.
Affected products
- Fedoraproject Fedora: 27
- Http-Proxy-Agent Project Http-Proxy-Agent: before 2.1.0 — fixed in 2.1.0
- Red Hat Enterprise Linux: 7.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: Http-Proxy-Agent Project Http-Proxy-Agent 2.1.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1567245
- https://www.npmjs.com/advisories/607
- https://bugzilla.redhat.com/show_bug.cgi?id=1567245
- https://www.npmjs.com/advisories/607
Get alerted when CVE-2019-10196 or the next vulnerability affects your stack