What’s Vulnerable › Vulnerabilities
CVE-2019-1020001
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
- Weakness: CWE-22
Description
yard before 0.9.20 allows path traversal.
Affected products
- lsegal yard: before 0.9.20 — fixed in 0.9.20
How to fix
Upgrade to a fixed version: lsegal yard 0.9.20. Check the vendor advisory for mitigations.
References
- https://github.com/lsegal/yard/security/advisories/GHSA-xfhh-rx56-rxcr
- https://lists.debian.org/debian-lts-announce/2024/03/msg00006.html
- https://github.com/lsegal/yard/security/advisories/GHSA-xfhh-rx56-rxcr
- https://lists.debian.org/debian-lts-announce/2024/03/msg00006.html
Get alerted when CVE-2019-1020001 or the next vulnerability affects your stack