What’s Vulnerable › Vulnerabilities
CVE-2019-1020014
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
- Weakness: CWE-415
Description
docker-credential-helpers before 0.6.3 has a double free in the List functions.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Docker Credential Helpers: before 0.6.3 — fixed in 0.6.3
- Fedoraproject Fedora: 32
How to fix
Upgrade to a fixed version: Docker Credential Helpers 0.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/docker/docker-credential-helpers/commit/1c9f7ede70a5ab9851f4c9cb37d317fd89cd318a
- https://github.com/docker/docker-credential-helpers/releases/tag/v0.6.3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6VVFB6UWUK2GQQN7DVUU6GRRAL637A73/
- https://usn.ubuntu.com/4103-1/
- https://usn.ubuntu.com/4103-2/
- https://github.com/docker/docker-credential-helpers/commit/1c9f7ede70a5ab9851f4c9cb37d317fd89cd318a
- https://github.com/docker/docker-credential-helpers/releases/tag/v0.6.3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6VVFB6UWUK2GQQN7DVUU6GRRAL637A73/
- https://usn.ubuntu.com/4103-1/
- https://usn.ubuntu.com/4103-2/
Get alerted when CVE-2019-1020014 or the next vulnerability affects your stack