What’s Vulnerable › Vulnerabilities
CVE-2019-1020015
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
Description
graphql-engine (aka Hasura GraphQL Engine) before 1.0.0-beta.3 mishandles the audience check while verifying JWT.
Affected products
- Hasura GraphQL: before 1.0.0; 1.0.0, 1.0.0-beta.1, 1.0.0-beta.2 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Hasura GraphQL 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/hasura/graphql-engine/commit/f2f14e727b051e3003ba44b9b63eab8186b291ac
- https://github.com/hasura/graphql-engine/commit/f2f14e727b051e3003ba44b9b63eab8186b291ac
Get alerted when CVE-2019-1020015 or the next vulnerability affects your stack