What’s Vulnerable › Vulnerabilities
CVE-2019-10206
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-22 · updated 2026-06-17
- Weakness: CWE-522
Description
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
Affected products
- Debian Linux: 10.0
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- Red Hat Ansible: from 2.6.0 before 2.6.19; from 2.7.0 before 2.7.13; from 2.8.0 before 2.8.4 — fixed in 2.6.19, 2.7.13, 2.8.4
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.6.19, 2.7.13, 2.8.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://www.debian.org/security/2021/dsa-4950
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://www.debian.org/security/2021/dsa-4950
Get alerted when CVE-2019-10206 or the next vulnerability affects your stack