What’s Vulnerable › Vulnerabilities
CVE-2019-10208
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-29 · updated 2026-06-17
- Weakness: CWE-89
Description
A flaw was discovered in postgresql versions 9.4.x before 9.4.24, 9.5.x before 9.5.19, 9.6.x before 9.6.15, 10.x before 10.10 and 11.x before 11.5 where arbitrary SQL statements can be executed given a suitable SECURITY DEFINER function. An attacker, with EXECUTE permission on the function, can execute arbitrary SQL as the owner of the function.
Affected products
- PostgreSQL: from 9.4.0 before 9.4.24; from 9.5.0 before 9.5.19; from 9.6.0 before 9.6.15; from 10.0 before 10.10; from 11.0 before 11.5 — fixed in 10.10, 11.5, 9.4.24, 9.5.19, 9.6.15
How to fix
Upgrade to a fixed version: PostgreSQL 10.10, 11.5, 9.4.24, 9.5.19. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10208
- https://www.postgresql.org/about/news/1960/
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10208
- https://www.postgresql.org/about/news/1960/
Get alerted when CVE-2019-10208 or the next vulnerability affects your stack