What’s Vulnerable › Vulnerabilities
CVE-2019-10209
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-29 · updated 2026-06-17
- Weakness: CWE-125
Description
Postgresql, versions 11.x before 11.5, is vulnerable to a memory disclosure in cross-type comparison for hashed subplan.
Affected products
- PostgreSQL: from 11.0 before 11.5 — fixed in 11.5
How to fix
Upgrade to a fixed version: PostgreSQL 11.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10209
- https://www.postgresql.org/about/news/1960/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10209
- https://www.postgresql.org/about/news/1960/
Get alerted when CVE-2019-10209 or the next vulnerability affects your stack