What’s Vulnerable › Vulnerabilities
CVE-2019-10210
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-29 · updated 2026-06-17
- Weakness: CWE-522
Description
Postgresql Windows installer before versions 11.5, 10.10, 9.6.15, 9.5.19, 9.4.24 is vulnerable via superuser writing password to unprotected temporary file.
Affected products
- PostgreSQL: before 9.4.24; from 9.5.0 before 9.5.19; from 9.6.0 before 9.6.15; from 10.0 before 10.10; from 11.0 before 11.5 — fixed in 10.10, 11.5, 9.4.24, 9.5.19, 9.6.15
How to fix
Upgrade to a fixed version: PostgreSQL 10.10, 11.5, 9.4.24, 9.5.19. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10210
- https://www.postgresql.org/about/news/1960/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10210
- https://www.postgresql.org/about/news/1960/
Get alerted when CVE-2019-10210 or the next vulnerability affects your stack