What’s Vulnerable › Vulnerabilities
CVE-2019-10216
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-27 · updated 2026-06-17
- Weakness: CWE-648
Description
In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.
Affected products
- Artifex Ghostscript: before 9.50 — fixed in 9.50
- Red Hat 3scale API Management Platform 2: 2.6
- Red Hat Enterprise Linux: 5.0, 6.0, 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.7
- RedHat Enterprise Linux Server Eus: 7.7
- RedHat Enterprise Linux Server Tus: 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.50. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=5b85ddd19
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10216
- https://security.gentoo.org/glsa/202004-03
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=5b85ddd19
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10216
- https://security.gentoo.org/glsa/202004-03
Get alerted when CVE-2019-10216 or the next vulnerability affects your stack