What’s Vulnerable › Vulnerabilities
CVE-2019-10218
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-22
Description
A flaw was found in the samba client, all samba versions before samba 4.11.2, 4.10.10 and 4.9.15, where a malicious server can supply a pathname to the client with separators. This could allow the client to access files and folders outside of the SMB network pathnames. An attacker could use this vulnerability to create files outside of the current working directory using the privileges of the client user.
Affected products
- Fedoraproject Fedora: 29, 31
- Samba: before 4.9.15; from 4.10.0 before 4.10.10; from 4.11.0 before 4.11.2 — fixed in 4.10.10, 4.11.2, 4.9.15
How to fix
Upgrade to a fixed version: Samba 4.10.10, 4.11.2, 4.9.15. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00015.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10218
- https://lists.debian.org/debian-lts-announce/2021/05/msg00023.html
- https://lists.debian.org/debian-lts-announce/2023/09/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OKPYHDFI7HRELVXBE5J4MTGSI35AKFBI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UMIYCYXCPRTVCVZ3TP6ZGPJ6RZS3IX4G/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XQ3IUACPZJXSC4OM6P2V4IC4QMZQZWPD/
- https://www.samba.org/samba/security/CVE-2019-10218.html
- https://www.synology.com/security/advisory/Synology_SA_19_35
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00015.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10218
- https://lists.debian.org/debian-lts-announce/2021/05/msg00023.html
Get alerted when CVE-2019-10218 or the next vulnerability affects your stack