What’s Vulnerable › Vulnerabilities
CVE-2019-10220
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Linux kernel CIFS implementation, version 4.9.0 is vulnerable to a relative paths injection in directory entry lists.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.04
- Debian Linux: 8.0
- Linux kernel: from 2.6.12 before 3.16.81; from 3.17 before 4.4.208; from 4.5 before 4.9.208; from 4.10 before 4.14.162; from 4.15 before 4.19.93; from 4.20 before 5.3.8 — fixed in 3.16.81, 4.14.162, 4.19.93, 4.4.208, 4.9.208, 5.3.8
How to fix
Upgrade to a fixed version: Linux kernel 3.16.81, 4.14.162, 4.19.93, 4.4.208. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10220
- https://lists.debian.org/debian-lts-announce/2020/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://security.netapp.com/advisory/ntap-20200103-0001/
- https://usn.ubuntu.com/4226-1/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10220
- https://lists.debian.org/debian-lts-announce/2020/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://security.netapp.com/advisory/ntap-20200103-0001/
- https://usn.ubuntu.com/4226-1/
Get alerted when CVE-2019-10220 or the next vulnerability affects your stack