What’s Vulnerable › Vulnerabilities
CVE-2019-10231
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-27 · updated 2026-06-17
- Weakness: CWE-843
Description
Teclib GLPI before 9.4.1.1 is affected by a PHP type juggling vulnerability allowing bypass of authentication. This occurs in Auth::checkPassword() (inc/auth.class.php).
Affected products
- Teclib-Edition Gestionnaire Libre De Parc Informatique: before 9.4.1.1 — fixed in 9.4.1.1
How to fix
Upgrade to a fixed version: Teclib-Edition Gestionnaire Libre De Parc Informatique 9.4.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/pull/5520
- https://github.com/glpi-project/glpi/releases/tag/9.4.1.1
- https://github.com/glpi-project/glpi/pull/5520
- https://github.com/glpi-project/glpi/releases/tag/9.4.1.1
Get alerted when CVE-2019-10231 or the next vulnerability affects your stack