What’s Vulnerable › Vulnerabilities
CVE-2019-10245
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-19 · updated 2026-06-17
- Weakness: CWE-20
Description
In Eclipse OpenJ9 prior to the 0.14.0 release, the Java bytecode verifier incorrectly allows a method to execute past the end of bytecode array causing crashes. Eclipse OpenJ9 v0.14.0 correctly detects this case and rejects the attempted class load.
Affected products
- The Eclipse Foundation Eclipse OpenJ9: before 0.14.0 — fixed in 0.14.0
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat Satellite 6: 5.8
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse OpenJ9 0.14.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108094
- https://access.redhat.com/errata/RHSA-2019:1163
- https://access.redhat.com/errata/RHSA-2019:1164
- https://access.redhat.com/errata/RHSA-2019:1165
- https://access.redhat.com/errata/RHSA-2019:1166
- https://access.redhat.com/errata/RHSA-2019:1238
- https://access.redhat.com/errata/RHSA-2019:1325
- https://bugs.eclipse.org/bugs/show_bug.cgi?id=545588
- http://www.securityfocus.com/bid/108094
- https://access.redhat.com/errata/RHSA-2019:1163
- https://access.redhat.com/errata/RHSA-2019:1164
- https://access.redhat.com/errata/RHSA-2019:1165
Get alerted when CVE-2019-10245 or the next vulnerability affects your stack