What’s Vulnerable › Vulnerabilities
CVE-2019-10640
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.7.10, 11.8.x before 11.8.6, and 11.9.x before 11.9.4. A regex input validation issue for the .gitlab-ci.yml refs value allows Uncontrolled Resource Consumption.
Affected products
- GitLab: before 11.7.10; from 11.8.0 before 11.8.6; from 11.9.0 before 11.9.4 — fixed in 11.7.10, 11.8.6, 11.9.4
How to fix
Upgrade to a fixed version: GitLab 11.7.10, 11.8.6, 11.9.4. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/49665
- https://about.gitlab.com/2019/04/01/security-release-gitlab-11-dot-9-dot-4-released/
- https://about.gitlab.com/blog/categories/releases/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/49665
Get alerted when CVE-2019-10640 or the next vulnerability affects your stack