What’s Vulnerable › Vulnerabilities

CVE-2019-10655

Description

Grandstream GAC2500 1.0.3.35, GXP2200 1.0.3.27, GVC3202 1.0.3.51, GXV3275 before 1.0.3.219 Beta, and GXV3240 before 1.0.3.219 Beta devices allow unauthenticated remote code execution via shell metacharacters in a /manager?action=getlogcat priority field, in conjunction with a buffer overflow (via the phonecookie cookie) to overwrite a data structure and consequently bypass authentication. This can be exploited remotely or via CSRF because the cookie can be placed in an Accept HTTP header in an XMLHttpRequest call to lighttpd.

Affected products

How to fix

Upgrade to a fixed version: Grandstream Gvc3202 Firmware 1.0.3.51; Grandstream Gxv3240 Firmware 1.0.3.219; Grandstream Gxv3275 Firmware 1.0.3.219. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-10655 or the next vulnerability affects your stack