What’s Vulnerable › Vulnerabilities
CVE-2019-10656
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-30 · updated 2026-06-17
- Weakness: CWE-78
Description
Grandstream GWN7000 before 1.0.6.32 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the filename in a /ubus/uci.apply update_nds_webroot_from_tmp API call.
Affected products
- Tenable Grandstream GWN7000: before 1.0.6.32 — fixed in 1.0.6.32
How to fix
Upgrade to a fixed version: Tenable Grandstream GWN7000 1.0.6.32. Check the vendor advisory for mitigations.
References
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
Get alerted when CVE-2019-10656 or the next vulnerability affects your stack