What’s Vulnerable › Vulnerabilities
CVE-2019-10657
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-30 · updated 2026-06-17
- Weakness: CWE-78
Description
Grandstream GWN7000 before 1.0.6.32 and GWN7610 before 1.0.8.18 devices allow remote authenticated users to discover passwords via a /ubus/uci.apply config request.
Affected products
- Tenable Grandstream GWN7000: before 1.0.6.32 — fixed in 1.0.6.32
- Grandstream Gwn7610 Firmware: before 1.0.8.18 — fixed in 1.0.8.18
How to fix
Upgrade to a fixed version: Tenable Grandstream GWN7000 1.0.6.32; Grandstream Gwn7610 Firmware 1.0.8.18. Check the vendor advisory for mitigations.
References
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
Get alerted when CVE-2019-10657 or the next vulnerability affects your stack