What’s Vulnerable › Vulnerabilities
CVE-2019-10659
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-30 · updated 2026-06-17
- Weakness: CWE-78
Description
Grandstream GXV3370 before 1.0.1.41 and WP820 before 1.0.3.6 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in a /manager?action=getlogcat priority field.
Affected products
- Grandstream Gxv3370 Firmware: before 1.0.1.41 — fixed in 1.0.1.41
- Grandstream Wp820 Firmware: before 1.0.3.6 — fixed in 1.0.3.6
How to fix
Upgrade to a fixed version: Grandstream Gxv3370 Firmware 1.0.1.41; Grandstream Wp820 Firmware 1.0.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
- https://github.com/scarvell/grandstream_exploits
- https://www.trustwave.com/en-us/resources/security-resources/security-advisories/?fid=23920&dl=1
Get alerted when CVE-2019-10659 or the next vulnerability affects your stack